Some systems are under maintenance.

Suku Drive - Email Notifications and Suku Uptime - Email Notifications

Fixed

6 days ago —

After 24 hours of close monitoring, we can confirm that the issue has been fully resolved. Emails should now be delivered successfully. We apologize for any inconvenience this may have caused and thank you for your patience.

Watching

6 days ago —

We have implemented a major fix. Some undelivered emails have been queued for delivery, while unfortunately some were lost. Once email traffic returns to normal, the queued emails will be delivered. We apologize for any inconvenience this may have caused.

Identified

6 days ago —

The issue has been identified. We are scaling our email infrastructure and expect the impact to decrease as the changes take effect.

Investigating

6 days ago —

We are actively investigating the issue and will provide further updates as more information becomes available.

1 week ago —

We are currently experiencing some email deliverability issues due to unusually high email traffic. The impact is limited, affecting less than 1% of our total emails per minute. Our team is actively monitoring the situation.

Incident UUID cf64fcda-c9f6-4516-b6f8-aab45b4d40f7