Some systems are under maintenance.

Suku Drive - Email Notifications

Fixed

6 days ago —

The backlog has been cleared and email delivery should now be functioning normally. Please disregard any delayed verification emails you may have recently received. If you continue to experience issues, contact our support team at support.sukudir.com .

Watching

6 days ago —

We are closely monitoring the email system to ensure that all verification emails are delivered promptly.

Investigating

6 days ago —

We recommend that affected users log in and request a new verification code to complete account verification.

Reported

6 days ago —

We identified that a system update caused a backlog in sending account verification emails, affecting approximately 5,000 users (less than 1% of total users).

1 week ago —

A small number of users (approximately 5,000, less than 1% of total users) may have recently received delayed account verification emails. These are backlogged notifications caused by a recent system update and are not security alerts. The issue affects only verification emails.

Incident UUID 6056ac41-ebe0-48c6-ada7-1a1d88bda38a